Page 1 of 1

Unwanted error message about hardware acceleration

PostPosted: Wed Feb 12, 2014 9:13 pm
by mkanet
I've been using Fastpictureviewer for several years now with the hardware acceleration setting enabled (even during remote RDP sessions) without any issues. Just recently, I started getting this annoying popup error message saying... "Hardware acceleration is not available at this time..." when I use FastPictureViewer during my remote RDP sessions.

The only way I know how to prevent this error message (and still use hardware acceleration when it's available) is to revert to an older version of FastPictureViewer.

Is there a way to disable this setting without disabling the hardware acceleration setting (or without reverting to an older version of FastPictureViewer)? If not, could the next version of FastPictureViewer have a way for the user to suppress this message from displaying?

Thanks in advance for improving FastPictureViewer!
MKANET

Re: Unwanted error message about hardware acceleration

PostPosted: Wed Feb 19, 2014 10:55 pm
by mkanet
Im still using the older version of FPV. Is there a chance we can see a solution for this? :D

Re: Unwanted error message about hardware acceleration

PostPosted: Sat Mar 15, 2014 3:26 pm
by Axel
The program is probably right, if you get this message then it could not initialize Direct3D in the required mode. Most likely D3D is not available in remote desktop sessions, the solution is to turn that option off in the program options.

If you get the same message in local installations, then the graphic adapter on that machine is unsuitable for the current requirments of the program. This may happen with some entry-level cards, some so-called integrated graphic adapters and/or certain combinations of cards and driver versions.

The program requirements evolved over time as more fuctions were moved to the GPU side. It is possible that an old version with less GPU accelerated features worked on a given driver/hardware but that newer versions don't.

For example we added GPU-based shadow/highlight clipping detections (C key) and GPU-based black and white preview (B kec) which works instantly but requires the use of pixel shaders and increased the requirements. This is just an example to illustrate the fact that the program evolves, and that older version may have had lower requirements.

If you leave the GPU acceleration option enabled, the program will warn you that it could not initialize the hardware the way it needs to. If you turn off that option, some features (like instant shadow/highlight clipping detection) will be disabled and other will run less quickly, but the program will work on any graphic card (and in remote desktop sessions).

Re: Unwanted error message about hardware acceleration

PostPosted: Fri Aug 15, 2014 5:45 pm
by mkanet
I'm not sure if this should go without saying or not; so, I'll just mention it... :)

The solution mentioned isn't a very practical solution for FVP users who also routinely accesses their desktop remotely.

With all older versions of FVP (from about a year ago and older); it didn't matter if the user was on their local Desktop or accessing it remotely. Full Hardware Acceleration "just worked", when possible. No hassle for the user. If HA wasn't available, it was still very obvious (because it's noticeably slower).

With the newer versions of FVP, there is no way to even suppress the warning message. So, the user is basically is forced to close this annoying warning message every time they Remote Desktop. It's really not feasible for the user to go into the FVP settings each time to disable HA. Then, the user would have to go back into the settings to re-enable the setting when go back to their local Desktop.

Is there a coding-related issue that would make it difficult adding a, "Suppress Hardware Acceleration Warning Message" check-box optional feature on newer builds?. If it's not too time consuming or complex, it would be great to gain this flexibility back in newer FVP versions.