Thumbnails in windows 7 loading v slow after installing FPV

Get help with installing and running FastPictureViewer: ask questions here. Please do not post presumed bug reports or suggestions here.

Thumbnails in windows 7 loading v slow after installing FPV

Postby alexrj on Thu Mar 29, 2012 9:07 pm

Hi guys, I'm having a nightmare here and help would be very much appreciated;

i have been using FPV for a while on 2 machines and also bought the jpg decoder to make jpg thumbnails the right way round. after installing FPV i noticed that windows thumbnails take alot longer to generate (you can see it do them one by one rather than just flying through the lot). also, if a folder contains enough pictures that you have to scroll down, before all the thumbnails would be generated instantly right to the bottom of the page where as now you have to scroll down and as you scroll the thumbnails slowly appear. this is no use to me as i deal with a huge number of pictures all the time.

i was putting up with the problem but i have just done a fresh install of windows 7 on one machine and the thumbnails are loading so fast its unreal. please can you tell me how to fix the issue or at least remove every trace of FPV so that windows will generate thumbnails like it used to on the machine i dont have a fresh install on.

a couple of friends have FPV home and they are both having the same problem without even installing the codec.

i have tried making the windows picture viewer the default program again and have removed all trace of FPV from programs and features. i really hope i dont have to do a fresh reinstall to fix this horrid problem

ive looked all over the net but cant find a solution. any wise words would be amazing

all the best
Al.
alexrj
 
Posts: 1
Joined: Thu Mar 29, 2012 8:54 pm

Re: Thumbnails in windows 7 loading v slow after installing

Postby Axel on Fri Mar 30, 2012 2:16 am

Right after installing the FastPictureViewer Codec Pack (or any other similar WIC-based codec(s)) the Windows Search Indexer grabs the properties of all the new files it now understands. This generates some disk activity and slows down the computer for some time, typically for a few hours but it can take longer if you have many files and/or your drives are not too fast. The dust settles down after a while and everything gets back to normal.

On Windows Vista and later the thumbnails are stored in a central database. Over time this database becomes large: it contains all the actual thumbnails, all in one file, for all files on all drives drives on the system. This database file can possibly become very fragmented over time, as it is always in use and thus never defragmented. As a result the system progressively becomes slower at creating thumbnails, and adding codecs only increases the number of thumbnails to be stored.

All of the above is just Windows doing its things: as far as we are concerned, our JPEG codec takes about 150 microseconds to extract and decompress the small embedded thumbnail, when present, and about 3 to 6 milliseconds to create a "large size" thumbnail from the full typical DSLR image data on a fast computer. Wherever the time you are seeing is spent, it's not in our codec!

Speaking of thumbnails, not all JPEG files contains one. When there is one it's usually quite small (like 160x120) and Explorer can only use it for creating "Medium" icons. For "Large" and "Extra Large" icons, as well as for displaying the large thumbnail in the metadata pane (lower-left), a larger thumbnail needs to be created from the full-size image data and this takes more time.

The fact that a fresh Windows install feels zippier than one with a long history is nothing new. Also the fact that you wrote that the slowness persisted after removing the FastPictureViewer Codec Pack, and that your friends experienced the same slowdown without installing it (!) leads us to believe that you need to look somewhere else for the cause of this problem...

Uninstalling from Windows Control Panel removes the codecs from your computer and they cannot possibly have any effect anymore. Finally, FastPictureViewer Pro does not ship with a JPEG codec for Explorer use and thus cannot possibly have any impact on Explorer performance regarding those files, even more so after you removed it from the machine 8-)

Faster disks and a boot-time defrag of the system drive from time to time may help a bit. If you want to discuss the specifics of your setup or want to dig deeped into this feel free to write to support @ fastpictureviewer . com
Axel
Site Admin
 
Posts: 794
Joined: Thu Nov 06, 2008 1:54 am
Location: Geneva, Switzerland


Return to User-to-User



cron