Page 1 of 1

Filters working?

PostPosted: Fri Dec 17, 2010 5:46 pm
by Endre
The latest version has a nice filter panel that opens on pressing F. However, I haven't managed to get filters to work (tried only filtering on XMP rating). I get erroneous behaviour whenever I set a filter: navigation between images is constrained, sometimes to the image displayed (ie. no navigation at all), sometimes to a few images which do not necessarily satisfy the filter conditions.

Are the filters supposed to work, or are they still at beta stage? Are there any guides on how to use them? I haven't found any.

Thanks in advance
Endre

Re: Filters working?

PostPosted: Sun Dec 19, 2010 4:54 am
by Axel
Filters need more work. We had to release some unrelated fixes and the filtering functionality came along but is not ready for prime time yet, thus we don't advertise it. The idea is indeed to constrain the navigation to images matching certain criteria.

The program will not reload the folder to filter-out non-matching images as this can be tedious when working with a large number of files. Instead, when a filter condition is set, the next click on the "Next" or "Previous" buttons will jump straight to the first (respectively last) image matching the filter conditions, and any further navigation will be constrained by the filter conditions. Setting (or changing) a filter is an instantaneous operation - running in constant time, aka O(1) - regardless of the number of images in the list, and so is clearing the filter condition, which just "frees" the navigation without reloading anything.

It turns out that this approach required a little more work than originally anticipated as the program has to observe the filters when preloading the next image(s), and as well as when displaying the thumbnail strip or when operated from the quick navigation slider or any of the keyboard navigation functions.

At the moment the filtering should work for the most basic uses, but what happens when no image match the filter, for example, needs more work. This feature will come to life in the next few builds and will be announced when ready, most likely the version number will be bumped to 1.4 as this represents an important piece of functionality.

Re: Filters working?

PostPosted: Mon Dec 20, 2010 2:36 pm
by Endre
Thanks for the backgrounder, Axel. Unfortunately I cannot coax even the most basic filtering functionality from FPV. I initially tried it on a folder with 600 pictures, then reduced it to 7 pictures, and it still only jumps between last and first image when I set the filter condition to XMP rating = n, even though there are several images with rating n in the folder.

Given that filtering doesn't work, I guess it's no surprise that file operations based on rules involving xmp ratings don't work either. I have tried a file copy operation triggered by the rule XMP rating >= 4, and FPV consistently froze on me.

I think that from a photographer's workflow viewpoint, this is the most pressing area for new feature development (bug hunting in the existing and extremely stable codebase as well as updates for new cameras excepted). FPV is squarely optimised for fast image review and rating - the next step would be to be able to act on those ratings. View filtering is even useful for refining the ratings assigned in a first step.

Thanks as always for your great work and responsive support,
Endre

Re: Filters working?

PostPosted: Fri Dec 24, 2010 2:32 am
by Axel
Endre wrote:Thanks for the backgrounder, Axel. Unfortunately I cannot coax even the most basic filtering functionality from FPV. I initially tried it on a folder with 600 pictures, then reduced it to 7 pictures, and it still only jumps between last and first image when I set the filter condition to XMP rating = n, even though there are several images with rating n in the folder.

I believed I wrote filters needed more work, and will be announced in v1.4 when ready 8-)

Endre wrote:Given that filtering doesn't work, I guess it's no surprise that file operations based on rules involving xmp ratings don't work either.

File operations are an entirely different matter. I'm not aware of any outstanding issue with these, and I know many users rely on them everyday. If you ran into a technical issue, please write to support with enough details to reproduce the problem, thanks.

Re: Filters working?

PostPosted: Sat Jan 08, 2011 3:28 pm
by Axel
v1.4 is available and View Filters should work a lot better now.

Re: Filters working?

PostPosted: Sat Jan 08, 2011 4:40 pm
by Endre
Yippee! Thanks Axel, I will try it right away.
Endre