Codec only works for the installing user on Win7?

Get help with installing and running FastPictureViewer: ask questions here. Please do not post presumed bug reports or suggestions here.

Codec only works for the installing user on Win7?

Postby gertfrost on Wed Apr 04, 2012 2:47 pm


I have tried to install the FastViewerCodec on a Windows 7 Professional (64bit). And for the user that installes it, it workes fine. But when I log on as another user, Windows Photo Viewer reports "Windows Photo Viewer can't open this picture because the file appears to be damaged, corrupted, or is too large".

Im trying to open a Canon CR2-raw-image.

I tried to "reverse" the installation, so the other user installed instead (after uninstalling), and now the other user got it to work, but the first user got the above error.

Can anyone explain this, and is there a fix/workaround?

thanks in advance
Posts: 1
Joined: Wed Apr 04, 2012 2:33 pm

Re: Codec only works for the installing user on Win7?

Postby Axel on Thu May 03, 2012 3:16 am

This can happen if the registry permissions were changed (for example by some security software or utility supposed to protect your computer). Locking down parts of the registry only causes issues with other applications and does not protect against anything but oh well...

When encountering this situation (the registration key cannot be saved by the installer) the setup routine falls back to a per-user location. As a result the product only works for the installing user, which is not perfect but better than failing the entire installation.

What you can do is install the product from User A, then switch to User B and uninstall the product, then reinstall it from User B. This will register the product for User B and since user partitions are segregated, the uninstall operation made from User B had no effect on user A registration.
Site Admin
Posts: 795
Joined: Thu Nov 06, 2008 1:54 am
Location: Geneva, Switzerland

Return to User-to-User